Posted on 5 Comments

WSJT-X 2.3 – Transmit Audio Failure with PiOS

Thanks to a report from John, GM0WRR, I have identified a problem with WSJT-X 2.3 and the use of PulseAudio on the Raspberry Pi.

When setting the input and output soundcard you would normally set both to pulse. However, if you do that, WSJT-X will fail after the first transmission. If you close and try to restart WSJT-X you will get a file lock error that you can’t clear. This is because, in its failled state, closing the program stops the interface but a WSJTX process is left running. To restart WSJT-X you need to reboot the Pi or Open the Task Manager (Accessories – Task Manager) and find wsjtx, right-click and kill it!

The work-around to this problem is to select the soundcard device, rather than pulse as the audio input and output.

Here’s a step-by-step process:

  1. With your USB soundcard or USB rig plugged in, start WSJT-X
  2. Go to File – Settings – Audio
  3. In the Soundcard, Input drop-down, select the entry that begins with: alsa_input.usb (it will probably be near the bottom of the list)
  4. In the Output drop-down, select the entry that begins with: alsa_output.usb (near bottom of list)
  5. Click OK to close and save the settings
  6. You should now be back in business.

Regards,

Mike – G4WNC

5 thoughts on “WSJT-X 2.3 – Transmit Audio Failure with PiOS

  1. Thank you this saved my bacon!

  2. It’s not just the Pi that is affected.
    I have the same problem with Ubuntu 21.04 and also 21.10 but in my case, selecting the Alsa device directly still doesn’t work.
    In fact, there is no option that works.
    After closing WSJTX, the “wsjtx” process is still running with 100% CPU.

    I also think that WSJTX’s list of sound devices lists a lot of option that shouldn’t be there….

    1. I have the same problem with a Raspberry Pi 3B+. Using a 705 with latest firmware version. The only thing WSJTS 2.3.0 accepts is default. Rejects any other choice. No audio in or out; alsamixer settings make no difference.
      When I try to close WSJTX and restart, the process is still running.

      1. It’s probably worth upgrading to the latest version of WSJT-X. On the Pi you can use my instructions HERE to easily build from source. It appears to be working fine here, though I don’t have any Icom rigs to test with.

        Regards,

        Mike

    2. I have found that when wsjt is “locked into run mode”‘
      opening a terminal screen (ctl-alt-t) then opening top,
      i can kill wsjt and go from there without having to reboot.

      same under Ubuntu.

      hope this helps some.

Leave a Reply to Dave Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.